Eclipse中出现-访问限制由于对必需的库XX具有一定限制,因此无法访问类型 的解决办法

作者: admin 分类: javaweb 发布时间: 2012-09-12 09:45 ė 6 Eclipse中出现-访问限制由于对必需的库XX具有一定限制,因此无法访问类型 的解决办法已关闭评论

我在调用 com.sun.rowset.CachedRowSetImpl 此接口时eclipse 出现此提示。感觉莫名其妙
google后 找到解决办法如下:
1、选择你的项目鼠标右键–>构建路径–>配置构建路径
2、展开JRE System Library 选中访问规则 点击编辑
3、点击添加 分辨率 选择可访问 规则模式 为 **
4、确定后就OK啦!

ps:由于本人安装Flash Bulider 4.5 插件的时候 自动汉化了eclipse – – 所以,英文版的同学请自己翻译吧。

本文出自weicms.net,转载时请注明出处及相应链接。

本文永久链接: http://www.weicms.net/2012/09/12/eclipse_xianzhi_jar.html

0
Ɣ回顶部